Car Runs The Same With Maf Unplugged

Description: How does a P0100 code trigger the check engine light? This code will trigger the check engine light under the following conditions: 1. plus woud your high oil consumption indicate it may not run totally smooth?. Either way the check engine light will come on due to the disconnected sensor. 91's, Blah, Blah. I have been searching the various nissan forums and I have tried:--New gasket for the throttle body,,,, cleaned the MAF,,,, checked the wires at the MAF plug, and the throttle body plugs. I actually was doing the same thing for about a month or so and finally decided to take it to get diagnosed. It idles low and doesn't run well but it runs. Based on some recommendations I read, I unplugged both POS and NEG terminals and touched them together for about 10 mins. I think I may also have a vaccum leak. The only codes that my laptop pulled was esc. A mass air flow can cause a vehicle to stall, hard start, hiccup, hesitation, transmission shift delay. Ya perfect sense (maybe because I've had a few - magic decoder ring phenom) it's the MAF unplug it at idle it it's fine. It doesn't run great with the MAF unplugged, but it won't run at all with it plugged in. It has a bad MAF sensor and I can't afford one right now. Car runs lean with maf plugged in / perfect when unplugged Discussion in '2005+ Mustang GT 4. It turns over, idles ROUGH and then dies. The replacement isn't an original part and behaves the same as the old one, which is running rough and cutting out at idle. When MAF hooked up no start | Find answers to your 2002 Nissan Altima question from certified mechanics and auto experts. I have replaced the Maf, no change. Like 3 weeks ago my car wouldn't go after 2000 rpms this happened after I washed my car. I've tried running the car with the knock sensors unplugged, and both lambda sensors unplugged. So I decided to unplug my iac and tps sensors to see if there was a change in idle with my car. Please view pictures and send us a message if you have any questions. I guarentee you its the mass airflow sensormy car had the exact same issues. unplugged my maf sensor - now car runs better I've been troubleshooting my 97 outback sport's intermittent rough running. A bad MAF sensor can cause some idle issues, backfire, not wanting to rev, bad gas mileage or lack of power in some cases. 1) Ignition Control Module (ICM) or coil / coils. stomp test again and same ol' 1213. I haven't cold-started the car with the MAF unplugged, but I bet this will get rid of my sluggish cold throttle response problem too. Re: Disconnecting MAP sensor (wiring) makes engine run great I hate to suggest parts tossing vs testing out to be certain. It eventually threw a code saying the MAF was unplugged, no surprise, but why was it running exactly like it did with the MAF plugged in? I would expect the car to run different without the MAF. An engine can run with the IAC disconnected if everything else is right. TCS light is normal for an unplugged MAF. I disconnected the MAF then started the car and it runs the exact same way as with the MAF connected,. My car has 90000 miles. My process is to first disable the maf and dial the VE table in. My first thought was a bad MAF but the more i read i see that it could be a few other things. It eventually threw a code saying the MAF was unplugged, no surprise, but why was it running exactly like it did with the MAF plugged in? I would expect the car to run different without the MAF. Larry stole the words right out of my mouth. Loss of power while HOT. Since I got my car I had a tps problem. A bad MAF sensor will generate a particular code, so it’s easy to tell whether this is the source of your car troubles. Better idle with Mass Airflow Sensor unplugged. If the same DTC doesn’t come back on KOEO, the sensor internals and wiring are probably electrically sound. 2 sxi - injection doc. I then thought it was just a faulty MAF sensor so I bought a new one. So I decided to unplug my iac and tps sensors to see if there was a change in idle with my car. So my question is: Until a new MAF arrives, what do I do? plug it back in or drive with it disconnected? I don't wan to hurt the cats, but it's obviously not working properly and runs better when unplugged. Plugged it back in, and the car started. If you unplug the mass air flow sensor the car will start. Check your intake hoses for cracks before replacing the MASS AIR FLOW SENSOR. MAF car runs the same when unplugged MAFland MAF car runs the same when unplugged - GN and T-Type Performance Enthusiasts (GNTTYPE) Forums This is a general site search and does not include list archives. now after I put everything back together the car won't run with the maf plugged in. But it halfway runs without the MAF plugged in. Just a low idle and surging if in park (limp mode). How to | Tell If You Really Need a Mass Air Flow Sensor | Auto Repair | Wesley Harrison | Clean|MAF - Duration: 3:59. I already unplugged it and it runs great so i am just curious. Diagnosing a bad MAF in a Selin Dual MAF setup. On a side note, if you are a VW purist make sure you spend the $150 for the bosch maf from the dealership, if you just want your 2000 passat to run, get a $30-$50 Chinese maf from ebay. So now that the wideband is hooked up to the scanner, you will be using Histogram 6 in the same scanner configuration. Comments: hi , i have a bmw 318is 1998. No, it will run with a proper mixture. Cant have smoke test and logs done until tomorrow now as the garage I use cant fit me in this evening. Difficult to road test to confirm fault in gear but owner states it does it on the road. If that doesnt do it replace the MAF sensor. it was a bitch to get it to run with out pedal pushen' but it ran on its own 1221 rpms. As you were driving with out the sensor so the best readings are stored. when i unplug the MAF the p0172 code goes away and the code for the MAF appears. no CEL, but the car still ran like crap and wouldn't acclerate. I’m concerned that it’s not regenerating with this fault and limp mode on, so the filter is blocking up – hence the second code. Air flow mass meter corsa unplugged. Since I got my car I had a tps problem. MAF units from 86-89 models output a simple analog signal instead of using frequency modulation like the 1985 units. I've tried with both old filter and old plugs installed vs new, the one variable between it working and not is the MAF being. stomp test again and same ol' 1213. Mass air flow hooked up car wont run unplug it car runs fine - Answered by a verified Mitsubishi Mechanic We use cookies to give you the best possible experience on our website. How to | Tell If You Really Need a Mass Air Flow Sensor | Auto Repair | Wesley Harrison | Clean|MAF - Duration: 3:59. The car is a 2004 Renault Kangoo fitted with a 16v 1. This is a discussion on Better idle with Mass Airflow Sensor unplugged within the General Help forums, part of the LSx Technical Help Section category; I have been chasing down an idle problem and decided to unplug the MAF to see if it would run. stomp test shows 1213 (secondary o2 lean/rich condition, same as before). It should at minimum start, even if it runs like shit at first [/quote] with the maf plugged in the car will start 5 seconds later die even if i have the car running at i try to plug maf in it'll kill it instantly even before the maf is clicked in all the way. MAF car runs the same when unplugged MAFland MAF car runs the same when unplugged - GN and T-Type Performance Enthusiasts (GNTTYPE) Forums This is a general site search and does not include list archives. Sometimes we experience an annoying hesitation or stalling when we are cruising in our cars and decide to accelerate either slightly or harder. The car runs fine. Here's a quick video on swapping the injectors. Fortunately, detecting bad MAF sensor symptoms is not rocket science. scanned via solus and have the p0130 oxygen sensor ! car has outmake cat and sensor fitted which looks fairly new. Thinking it was just a MAF I brought a know good MAF from a 93 TSI talon and swapped it but it didn't change anything. she runs way to rich, maf plugged in i only get idle if i hit the gas the least bit she dies, now if i unplug the maf she runs like a raped ape, just too rich. Yes You can drive the car with the MAF unplugged. Your ECU will use preset maps (open loop) to run. Leave the MAF plugged in. i have a problem with a lt1, it will start and die after a few seconds of running. It will run and as soon as I put the maf in the housing , the engine stalls. If you just experience a rough idle (or something like that) but the car is running fine while driving, it isn't likely that your MAF is shot, even when you measure 1,4 volt at #3. Now while the car was running I unplugged the MAF and the car runs PERFECT. If there was a vacum leak it would throw a code. What does the MAF actually do? Discuss problems you have had or are having with your Z4. A MAF, mass air flow sensor, measures the amount of air passing through the air filter for use in combustion,(if it isnt measuring accuratly, your engine wont perform properly) were as an EGR exhaust gas recirculation valve, opens on over run to bybass exhaust gasses back into the combustion chamber to burn it a bit more!!!!. Emmitt Unplugged High-voltage running back Emmitt Smith of the Dallas Cowboys may look as if he's relaxing, but don't be fooled. I've read it could be the cam sensor, so today I unplugged it after I started the car. If there's any air leak at or after the MAF, that is a problem. Nothing more nothing less, check those 3 things. While the car is running if I plug the MAF in, the car dies instantly. no codes came on right away, but it was misfiring like you wouldn't believeso i replaced the MAF and it was magic. It invariably means a problem with the air measurement ! A MAF could be the cause, but anything that makes the airflow measurement less than accurate will have the same effect. Also I found one spark plug boot that was arcing a little Check your plug wires. i thought the MAF was bad prior to replacing it since when i unplugged it the car ran perfect. The MAF codes can be 66 or 25. Is it my throttle body or TPS, perhaps a bad PCM. All this is in my own experience, Skoda Octavia Vrs running 220+ bhp thanks to a jabba remap. If you suspect your MAF is bad, simply unplug it. I cleared the codes and the only remaining ones that came back were the MAF code and I am without traction. MAF sensor was cracked and throwing a code, so I replaced it. Hi Tezray, Engine will run rich with MAF disconnected, so not advisable to leave for long periods. Can a car run with bad mass air flow sensor? Answer. Just completed a single turbo conversion. MAF sensor was cracked and throwing a code, so I replaced it. I was wondering if anything bad would happen to my car if it is unplugged. started car. Quell that irrational itch when your Google Home device doesn't work like it should with this quick troubleshooting guide. Naturally, I thought the maf was bad, but when I swapped the maf (with a known good one) I have the same problem. The main cause of most P0171 codes on the 4runner is the MAF sensor, which also has the air temperature sensor on it, a faulty air temperature sensor on your MAF can cause a running rich problem. if your going to clean the MAF use electrical contact cleaner. if you uplug the MAF and problem goes away then you have a bad MAF sensor. so i decided to test see if the MAF sensor was my issue for bad gas milage so i unplugged it and started the car seems no different in sound. Pedro is right about the crankshaft position sensor. If it runs better with the MAF unplugged it invariable means a duff MAF. for the values of the faulty maf, the engine will then have to re-learn these for the. In this article I'll show you how to do it in a step-by-step fashion that will either condemn the mass air flow (MAF) sensor as BAD or exonerate it. Hope this helps. The car does the same thing everytime and it is imposible to rev it over 2k rmp without the car shutting itself after a few intake backfires. I was wondering if anything bad would happen to my car if it is unplugged. then its starts stalling and backfireing when driveing , this may last up to 40 sec then the car will run fine again. Troubleshooting will be the same for both codes. It may run shitty but should not shut off. Jun 5, 2015 #1. For instance, on a returnless system you can use a dual outlet regulator and run one line each, to the two fuel rails. The car will start and seems to run fine for a few seconds. Should be only about $50 for a good core, and a lot less problems. 7x at idle and functions normally. Anyhow I got out the multimeter and measured the current on the TPS and I found this The TPS has 5v even while the car is just idling at 900rpm. When MAF hooked up no start | Find answers to your 2002 Nissan Altima question from certified mechanics and auto experts. There are various designs of MAF sensors, but the most common by far is the hot wire MAF sensor. The mass air flow sensor (MAF) is located inside the engine compartment and is used to measure the amount and temperature of air that is entering the engine at any one time. the car runs smoother through the rev range, and fuel economy is the same or better. The car is a 2004 Renault Kangoo fitted with a 16v 1. the result is i need a extra gear (6 speed. if its a fault MAF, run car with it unplugged. To test if it is the MAF disconnect the pigtail and start the car. Yes, but not very well. To test it just disconnect the wire going to it and drive around for a few days. In the last week I was running a full tank of high octane gasoline + aditive for injectors. when a vehicle comes in thats running poorly or has stumble when acclerating, after checking basic fuel pressures and spark KV. The EFI system isn't really that complex on a fox body Mustang, it has a few sensors, solenoids, relays and a computer handling all this input to strive for the best fuel ratio for most performance and mileage in all possible conditions. for the values of the faulty maf, the engine will then have to re-learn these for the. Tried 2 different maf sensors, nothing worked, maybe a bigger issue asked in Electrical and Lighting / Misc about a 2006 Impreza 2. 3L Power Stroke Diesel - Why does my truck run better with the MAP sensor unplugged - I've been beating my head trying to figure out the problem with my wife's truck. This year has been crazy we played more than 108 gigs all over the world, still running the farm at the same time, it was unsane but we did it. Hours later it ran but with the same symptoms so I looked under the hood and the MAF sensor was accidentally unplugged. now after I put everything back together the car won't run with the maf plugged in. I plugged it back in and the car wouldn't crank. When MAF hooked up no start | Find answers to your 2002 Nissan Altima question from certified mechanics and auto experts. I've tried cleaning and replaced maf with another one and got same results, both times disconnecting the battery to let computer reset. on cars with both map and maf the pcm will also use the map sensor to check the egr and other rationality checks. It is a little sluggish and hesitates when I press the gas pedal. no codes came on right away, but it was misfiring like you wouldn't believeso i replaced the MAF and it was magic. Nothing more nothing less, check those 3 things. OEM quality product. so it mustve been broken). I left it. Car runs same with WUR unplugged? I think I understand what WUR does. You could try a can of MAF cleaner which is only like $7-8 & if that doesn't work you might want to look into replacing it. The only codes that my laptop pulled was esc. The MAF codes can be 66 or 25. Surprise-surprise. " Now for my own trouble shooting: I guessed that there might be a problem with the Mass Air Flow sensor. Turned it off. This is a good job for DIYers and shouldn't take too long. Bad mass air flow sensor symptoms vw cause misfire. Once it has had time to dry, reinstall the same way you took it out, making sure to reattach the cables. I guarentee you its the mass airflow sensormy car had the exact same issues. I have a 1995 mustang, 5 speed, 3. The only thing it accomplishes is to set another code. If the fault continues then the MAF isn't to blame. Vauxhall - Vivaro 2005 1. Car won't run with crankshaft position sensor plugged in (2003 Nissan Maxima) I have a 2003 Maxima 6 speed, I just replaced the engine, at first I kept getting the p0335 code, but the car would take a long time to start but eventually it would start and run strong. Have the maf set at 0hrtz. Naylz Newbie Posts: 44 Joined: Mon Mar 11, 2019 9. Power is pretty much gone. 9 posts • Page 1 of 1. If the car doesn't start with the MAF disconnected try disconnecting the battery for 10-15 mins then try starting it with the MAF disconnected. MAF sensor - is it the same thing as a ' Air Intake / Charge Temperature' Sensor? Page 2 - Seeking answers? Join the AnandTech community: where nearly half-a-million members share solutions and discuss the latest tech. The car runs better without it plugged in. Car runs better without MAF plugged in after VVTi single build. Of course, there are many other reasons why your car might not be running properly, so today we're going to explain how to diagnose a bad or failing air flow meter and see what's involved in fixing it. Remove the MAF's connector (again with the tab). The difference between the two codes is the consistency of the malfunction in the MAF sensor circuit. Leave an electric car unplugged for a while, and the same happens. He touches the air filter box and its hot, while the intake is cool. Q: Car runs with the mass airflow sensor unplugged. Kurt Cobain’s ‘Unplugged’ sweater sells for $437K The seller — who is a diehard Cobain fan — initially bought the sweater back in November of 2015 for just over $180,000. How to | Tell If You Really Need a Mass Air Flow Sensor | Auto Repair | Wesley Harrison | Clean|MAF - Duration: 3:59. 6L Tech' started by Aesthetics28, Jun 5, 2015. The MAF sensor appears to be sending values back to the ECU, but the car stays in limp mode even after a reset. I've tried another MAF from a junkyard and it does the EXACT same thing (But I saw the connection bent on that one. The mass air flow sensor is a possibilitytry leaving the mass air flow sensor wire harness unplugged to see if the car runs better. The one time I removed the MAF to clean it it happened. Just completed a single turbo conversion. while driving the car it warms up and becomes dependant on the maf sensor to run the car properly. However, it starts and idles perfectly without the MAF. I have a rough idle, mid range on rpms it will clear out, any higher it will start to stumble. The last time I tried that test, it seemed to run better with the MAF disconnected, so I replaced the MAF (new Bosch part). A mass air flow can cause a vehicle to stall, hard start, hiccup, hesitation, transmission shift delay. My question is, can I just leave the O2 sensor unplugged, or does that make it run too rich and it's not good for. (go easy on the little wire , just give it a gentle burst)don't spray the stuff full force on the sensor wire , just give it enough to clean it off. That brings up the question of can your car run without the mass air flow sensor? In this article, we will look at what happens when you disconnect the mass airflow sensor. It either fires all four injectors on a (for example) 100ms interval, or two injectors every 50ms. Jump to Latest Follow 1 - 6 of 6 Posts. No change in the engine idle while it was unplugged. Replace it with a new ACDelco unit or get an ACDelco from the junk yard. Just try unplugging the MAF for a run and see how it goes. So I unplugged it. And when the sensor is damaged, the computer is simply not able to ensure the right mixture. I then tried starting the truck with the maf plugged in , but out of housing. It detects any engine noises caused by detonation -- when fuel explodes in an engine's cylinder-- and adjusts ignition timing accordingly. That should do it. Mass Airflow Sensors (MAF) report the amount or density (Mass) of the air entering the engine to the Powertrain Control Module (PCM). The WOT prescription can be met at throttle openings as low as 50% to 70%. - Need to determine what MAF i should be using (old vs new) - New Coils, NGK plug wires, Igniters have good ground, engine is grounded to the body. Those things never burn out, just like the AB light!! Years ago I had a Ford Taurus that I bought as salvage (someone hit a deer with it and the passenger AB went off) put it together and drove it for the work car. (flat tappets can't be ground to the same profiles that a roller can) If your intent on keeping the 289, for what ever reasons, do look into doing a roller conversion on it. it runs well whitout maf sensor, but wont start with the Maf connected. If vagcom is throwing up MAF issues, and the car is running sqeet after you have unplugged the MAF, then it is well worth getting the MAF replaced (although sometimes a good clean will do the trick), clear all your vagcom errors, re-test and see what it throws up. My MAF is on the blink so it has been unplugged. Ran fine for a couple drives, now car will not start. Had head cleaned and new valve seals installed. Cold start with MAF disconnected it will idle smoothly. When the oxygen sensor in your car goes bad, your car runs differently. Then it went full rich with black smoke on the first maf. A newer car computer is much more sophisticated, and just because a "CHECK ENGINE" light comes on doesn't really mean the computer is totally in a "limp home mode". As you were driving with out the sensor so the best readings are stored. Have the maf set at 0hrtz. I left it. The basic principle behind the operation of all MAF sensors is the same. The above mentions the ECU running on a default setting. My first thought was a bad MAF but the more i read i see that it could be a few other things. The car is a '97 Merc E200. I have an 04 Tacoma DCSB and I replaced my MAF cause it had a crack in the glass element. My car has 90000 miles. In fact that is one of the test you can do to determine if the MAF is bad, if the car stumbles doesn't run right with it plugged in and maybe you have a 121 code, unplug it and if it runs OK then pretty sure bet the MAF is bad. I replaced the coilpacks in my car with the 2. With the MAF unplugged the car is running in speed density mode, which just says (as I understand it - which isn't much) at this rpm, there's this much air flowing and you need this much fuel, instead of going off of actual air flow. One is the car losing water and other is the engines overheating problems. I expected a big difference since my trim was supposedly at -30% now. So I unplugged it. They ended up having the same issue I had. I figured it might be a bad MAF so I swapped it out and the same thing occurred. It doesn't feel like it's got an ignition/spark issue. Either way the check engine light will come on due to the disconnected sensor. Read on the original site. Remove the 3 screws (7mm head) holding the MAF in place. With the MAF unplugged you will get the engine light and code pop up and the car will not run 100% right. Have the maf set at 0hrtz. Add Horsepower and Save Gas With a Performance Filter System: I'm going to tell you how to add horsepower and save gas with a Performance Filter System. Nothing more nothing less, check those 3 things. Bad mass air flow sensor symptoms vw cause misfire. Because the box comes from a car that runs 70mm pipes it only has a 70mm outlet. Plugged "left MAF" back in, engine idle same. -Swapped the MAF's with a set that works fine on another car, still runs. Unplugged the MAF while running and the car doesn't run any different at all with the MAF unplugged, it still runs the EXACT same with the MAF unplugged it just wont rev past 2500rpm. Recently P0171 came on. Rather than a WOT snap from idle, an uphill downshift at 20 to 30 mph is usually sufficient. The difference between the two codes is the consistency of the malfunction in the MAF sensor circuit. Last week while out-and-about I decided to stop the car, leave it running, pop the hood, and try the "unplug the MAF" maneuver that had been described in several forum posts. the computer then gets reading from MAP sensor when MAF sensors go out. Comments: hi , i have a bmw 318is 1998. When the sensor is plugged it my car does not start. So I recently did the z31 ECU/Maf swap on my 73 s30 with 81 l28ET. Anyway, the short of it is that after reconnecting everything, I started the car and let it run for 10 minutes at idle. It doesn't feel like it's got an ignition/spark issue. I suspected immobilizer and performed the lock and unlock with the key remote 5 times with no effect. So I unplugged it. The interesting thing is that if I disconnect the MAF sensor the car runs smooth but idles around 3k rpms (very high). The car will start and seems to run fine for a few seconds. If it is your maf that shows up bad after a scan, well sometimes the only thing you can do is replace the maf. I have been having car woes the last two days. unplugged the engine runs ok and revs (but quite rich). I have monitored the g/s intake flow of air and at idle it's 19-22 g/s and at full throttle the reading is about 70-80 g/s. Tried 2 different maf sensors, nothing worked, maybe a bigger issue asked in Electrical and Lighting / Misc about a 2006 Impreza 2. Testing to see if the MAF sensor on your 3. Note: The use of “oiled” air filters can cause the MAF to become dirty if the filter is over-oiled. I've driven about 75 miles with the maf wire inbetween the air filter and intake not connected. You could run a new air filter. It barely starts, misses like crazy and just isn\'t running smooth. plus woud your high oil consumption indicate it may not run totally smooth?. i thought the MAF was bad prior to replacing it since when i unplugged it the car ran perfect. hi, well as you say it will only run with the CPS disconnected this leads me saying the flywheel is bolted on in the wrong postion; The cars ECU works out that the CPS signal isn't in the correct position or the signal isn't the correct waveform it will then read the cam signal and run the car on the cam signal, this will also stop the variable cam control not to work this can be also looked. The mass air flow sensor (MAF) is located inside the engine compartment and is used to measure the amount and temperature of air that is entering the engine at any one time. Hope this helps. Not really missing, just kills if the MAF is plugged in and definitely doesn't do low speeds well without stumbling and killing. It causes the car to overfuel which will eventually over time coke up sensors and the internals, and will eventually kill so many things. Hi I have fitted an Egr blanking plate today and the car seems more responsive lower down but it's still slow after say 2000rpm as though the turbo not having any effect (definitely slower to pick up than the C4 1. It runs a predefined map from the ECU. If your car is running better with maf unplugged then a) ur maf was bad b) it was getting bad reading c) u have a leak in ur intake track and or pulling in unmetered air. Started car with maf sensor unplugged, contact dealer warning? Discussion in ' VE Holden Commodore (2006 - 2013) ' started by vrollin , Jan 1, 2012. If the engine stumbles or stalls, the sensor is faulty. hard to say on mafs as they can do weird thigs from car to car - it seems to vary from car to car depending on how well the rest of the car is as to how it acts when unplugged - mine runs smooth with the maf unplugged, my mates runs lumpy so i do know its hard to say without diagnostics and even then tbh ,,, my maf passed the pre remap. I have that same problem 2000 328I sedan but unplugged it runs fine but burns more gas! when plugged im afraid it cuts out because at stand stills the car rattles horribly im currently driving the car with the sensor unplugged. Something came unplugged in my Mercedes C240? Mercedes C-Class Forum. when it was plugged in the car ran soo rich that it actually would kill the motor. The mass air flow sensor (MAF) is located inside the engine compartment and is used to measure the amount and temperature of air that is entering the engine at any one time. just because its bad doesnt mean it will set a code. Running with MAF unplugged, bad idea? MAF unplugged it runs fine. Ive checked for breaks in the wires but still nothing. They ended up having the same issue I had. A MAP or a MAF will have 3 wires. If it runs better with the MAF plugged in, it should be ok. The mass airflow sensor is a key sensor in your car. As a model year progresses other variables, like part lot numbers and such can cause one car to run much better than the next. It sounds like ur problem is c, check for leaks in intake track (intake tube, throttle body gaskets and connections etc. #1943: Cream Rinse. 2400 revs in any gear. I think we've ruled out a spark plug or coil fault on cylinder three. So i unplugged the MAF and it runs great now, now stutter at start up and full throttle is just fine but now of course i am throwing a p0102 code. How to | Tell If You Really Need a Mass Air Flow Sensor | Auto Repair | Wesley Harrison | Clean|MAF - Duration: 3:59. 1) Ignition Control Module (ICM) or coil / coils. OEM quality product. Replace it with a new ACDelco unit or get an ACDelco from the junk yard. I ran the codes and there was the same MAF code along with a few cylinder misfired codes. I'm at a loss. If vagcom is throwing up MAF issues, and the car is running sqeet after you have unplugged the MAF, then it is well worth getting the MAF replaced (although sometimes a good clean will do the trick), clear all your vagcom errors, re-test and see what it throws up. I have been searching the various nissan forums and I have tried:--New gasket for the throttle body,,,, cleaned the MAF,,,, checked the wires at the MAF plug, and the throttle body plugs. I've cleaned the wires with MAF cleaner and checked the output signal on the sensor previously when the problem was intermittent, and it was normal. Two days later, the Check Engine Light came back on and after running the diagnosis again, the stupid P01101 MAF sensor code showed up again. A MAF sensor that continuously over-reports or under-reports airflow into the engine will cause an engine to run rich or lean. Is the FRP MAF the same as Still feel the car 'bounces' a little. If the car runs normally then you have a dodgy MAF. Quell that irrational itch when your Google Home device doesn't work like it should with this quick troubleshooting guide. I had been running an aftermarket filter since July, and figured out that might be a cause to the problem. Have the maf set at 0hrtz. I already unplugged it and it runs great so i am just curious. i had the same problem with my buddy 91. I have a Conforti chip so I figure the chip is basically giving the car more fuel at all RPMs which is why it runs richer without the O2 sensor plugged in. Look through it, and see if any of the holes in the air straightener are munged. Gender: Men Item Type: Outerwear & Coats Outerwear Type: Jackets Brand Name: liilgal Sleeve Style: Regular Collar: Stand Lining Material: Polyester Thickness: Standard Closure Typ.